Computer-Masters.de > Forum von Computer-Masters.de
icon
Avatar
derDieb
Beiträge: 6
Hi,

Ich kann X forwarding auf meiner OpenSuse 13.1 Maschine irgendwie nicht verwenden.
Die bash Session sieht in etwa so aus:

iconCode:
ssh -X root@XXXXX
Password: xxxx
X11 forwarding failed on channel 0


Dann hab ich einfach nur Konsolenbasiertes Ssh und da läuft alles.

Ich habe aber alles in der ssh_config alles richtig eingestellt uund auch schon ein sshd restart ausgeführt. Ich kann mit der Fehlermeldung nichts anfangen und auf meiner Ubuntu-Kiste läuft das auch.
Jemand ne Idee waran das liegt?

MfG
derDieb
Intel i7-2600k - GTX 570 - 8 GB DDR3 - ASUS Xonar DX 7.1 - Samsung SSD 840 Pro Series 256GB - WD Caviar Green 3TB - Windows 7 Home
2014-04-10 09:03
Avatar
Matthias_S
Webmaster
Beiträge: 26
Hallo,

Das ist ein Bug in OpenSuse:
http://lists.opensuse.org/opensuse-bugs/2011-08/msg03636.html

Wenn du in /var/log/messages nachliest, solltest du dort folgendes finden:
iconZitat:
error: Failed to allocate internet-domain X11 display socket


Die Lösung des Problems ist, wie auf der verlinkten Seite beschrieben IPv6 zu deaktivieren (auch wenn man eigentlich Ipv4 verwendet):
iconCode:
sysctl net.ipv6.conf.all.disable_ipv6=0


Hier aber erst mal den Netzwerkadministrator fragen ob das keine anderen Probleme erzeugt.
Nach einer Neuanmeldung über ssh -X sollte X11 forwarding funktionieren.
Mit freundlichen Grüßen
Matthias Schöpe - Webmaster
http://www.Computer-Masters.de
2014-04-10 09:08
icon
Computer-Masters.de > Forum von Computer-Masters.de

Anzeige: